Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(185)

Issue 10905211: Clean up operator names. (Closed)

Created:
8 years, 3 months ago by ahe
Modified:
8 years, 1 month ago
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Clean up operator names. Committed: https://code.google.com/p/dart/source/detail?r=14942

Patch Set 1 : #

Total comments: 8

Patch Set 2 : Rebased #

Patch Set 3 : Address review comments #

Patch Set 4 : Added test #

Total comments: 7

Patch Set 5 : Address review comments #

Unified diffs Side-by-side diffs Delta from patch set Stats (+130 lines, -92 lines) Patch
M dart/sdk/lib/_internal/compiler/implementation/closure.dart View 1 2 1 chunk +11 lines, -16 lines 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart View 1 2 3 4 1 chunk +84 lines, -54 lines 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart View 1 2 2 chunks +3 lines, -1 line 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/mirrors/dart2js_mirror.dart View 1 2 2 chunks +6 lines, -2 lines 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/resolution/members.dart View 1 2 3 4 1 chunk +7 lines, -2 lines 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/ssa/builder.dart View 1 2 1 chunk +1 line, -1 line 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/ssa/optimize.dart View 1 1 chunk +1 line, -1 line 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/types/concrete_types_inferrer.dart View 1 2 2 chunks +9 lines, -5 lines 0 comments Download
M dart/sdk/lib/_internal/compiler/implementation/util/link.dart View 1 1 chunk +0 lines, -1 line 0 comments Download
M dart/tests/compiler/dart2js/find_my_name_test.dart View 1 2 1 chunk +1 line, -2 lines 0 comments Download
A + dart/tests/language/operator_negate_and_method_negate_test.dart View 1 2 3 4 1 chunk +7 lines, -7 lines 0 comments Download

Messages

Total messages: 10 (0 generated)
ahe
8 years, 3 months ago (2012-09-11 10:21:29 UTC) #1
ahe
Hi Florian, I would appreciate your thoughts on this. Cheers, Peter
8 years, 2 months ago (2012-10-16 21:24:46 UTC) #2
floitsch
I'm concerned that JS will run slower, but otherwise LGTM. You could also modify the ...
8 years, 2 months ago (2012-10-17 12:13:46 UTC) #3
erikcorry
https://chromiumcodereview.appspot.com/10905211/diff/3002/dart/lib/compiler/implementation/elements/elements.dart File dart/lib/compiler/implementation/elements/elements.dart (right): https://chromiumcodereview.appspot.com/10905211/diff/3002/dart/lib/compiler/implementation/elements/elements.dart#newcode1780 dart/lib/compiler/implementation/elements/elements.dart:1780: return op; Having property names that are not valid ...
8 years, 2 months ago (2012-10-17 12:46:39 UTC) #4
ahe
PTAL https://chromiumcodereview.appspot.com/10905211/diff/3002/dart/lib/compiler/implementation/closure.dart File dart/lib/compiler/implementation/closure.dart (right): https://chromiumcodereview.appspot.com/10905211/diff/3002/dart/lib/compiler/implementation/closure.dart#newcode489 dart/lib/compiler/implementation/closure.dart:489: String value = name.stringValue; On 2012/10/17 12:13:47, floitsch ...
8 years, 1 month ago (2012-11-12 13:22:09 UTC) #5
ahe
FWIW, I have verified that DeltaBlue and Richards aren't suffering any performance degradations.
8 years, 1 month ago (2012-11-12 13:22:38 UTC) #6
ahe
Added a test case.
8 years, 1 month ago (2012-11-12 13:30:38 UTC) #7
ngeoffray
LGTM http://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart File dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart (right): http://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart#newcode1808 dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart:1808: * For non-operator names, this metod just returns ...
8 years, 1 month ago (2012-11-13 11:56:19 UTC) #8
ahe
Thank you all for your comments and suggestions! https://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart File dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart (right): https://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart#newcode1808 dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart:1808: * ...
8 years, 1 month ago (2012-11-15 07:00:33 UTC) #9
ngeoffray
8 years, 1 month ago (2012-11-15 11:15:58 UTC) #10
https://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/co...
File dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart
(right):

https://codereview.chromium.org/10905211/diff/17003/dart/sdk/lib/_internal/co...
dart/sdk/lib/_internal/compiler/implementation/elements/elements.dart:1808: *
For non-operator names, this metod just returns its input.
On 2012/11/15 07:00:33, ahe wrote:
> On 2012/11/13 11:56:19, ngeoffray wrote:
> > Should this method be named mapPotentialOperatorNameToIdentifier ?
> 
> This method really maps an arbitrary method name to a valid Dart identifier. 
I
> can rename it to methodNameToIdentifier, but that doesn't feel like an
> improvement.
> 
> Let me know what you think.

I find the use of operator in the name of this method confusing. So I'd prefer
your suggestion of using methodNameToIdentifier instead of
operatorNameToIdentifier.

Powered by Google App Engine
This is Rietveld 408576698