Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(344)

Issue 9169045: Refactoring only: Extracted 2 methods from ClearNonLiveTransitions (Closed)

Created:
8 years, 11 months ago by Sven Panne
Modified:
8 years, 11 months ago
Reviewers:
Michael Starzinger
CC:
v8-dev
Visibility:
Public.

Description

Refactoring only: Extracted 2 methods from ClearNonLiveTransitions This simple refactoring makes it very clear that clearing non-live transitions actually consists of 2 quite separate things. Things would even be nicer if the prototype transitions were represented by a separate data structure instead of reusing FixedArray in an interesting way once again. As an additional bonus, this CL makes it possible to read each of the methods in question on a 30" screen without scrolling! Committed: https://code.google.com/p/v8/source/detail?r=10501

Patch Set 1 #

Total comments: 2

Patch Set 2 : Incorporated online and offline review suggestions #

Unified diffs Side-by-side diffs Delta from patch set Stats (+79 lines, -73 lines) Patch
M src/mark-compact.h View 1 1 chunk +2 lines, -0 lines 0 comments Download
M src/mark-compact.cc View 1 1 chunk +77 lines, -73 lines 0 comments Download

Messages

Total messages: 2 (0 generated)
Sven Panne
8 years, 11 months ago (2012-01-25 12:34:04 UTC) #1
Michael Starzinger
8 years, 11 months ago (2012-01-25 13:15:47 UTC) #2
LGTM (if comments are addressed).

https://chromiumcodereview.appspot.com/9169045/diff/1/src/mark-compact.cc
File src/mark-compact.cc (right):

https://chromiumcodereview.appspot.com/9169045/diff/1/src/mark-compact.cc#new...
src/mark-compact.cc:2367: void
MarkCompactCollector::ClearNonLiveMapTransitions(Map* map, bool marked) {
I don't like boolean flags, they are very confusing. Can we instead pass the
map's MarkBit (i.e. map_mark)? Thereby you can reuse that as the initial
current_mark value as well and it is clear what that argument means.

https://chromiumcodereview.appspot.com/9169045/diff/1/src/mark-compact.cc#new...
src/mark-compact.cc:2382: MarkBit current_mark = Marking::MarkBitFrom(current);
Like the above comment said: Initialize outside of loop and update at end of
loop after line 2398.

Powered by Google App Engine
This is Rietveld 408576698