Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(4532)

Unified Diff: base/metrics/sparse_histogram.cc

Issue 17451016: [UMA] Remove redundant bucket_count variable from base::Histogram. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src
Patch Set: Rename variables to be clearer Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/metrics/sparse_histogram.h ('k') | base/metrics/statistics_recorder_unittest.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/metrics/sparse_histogram.cc
diff --git a/base/metrics/sparse_histogram.cc b/base/metrics/sparse_histogram.cc
index 21dd2ab7d97aecd12ca5a6a77083804ad1f75ec1..737ccad72f23553837ffebf47c2c4eaf59213ed5 100644
--- a/base/metrics/sparse_histogram.cc
+++ b/base/metrics/sparse_histogram.cc
@@ -39,9 +39,10 @@ HistogramType SparseHistogram::GetHistogramType() const {
return SPARSE_HISTOGRAM;
}
-bool SparseHistogram::HasConstructionArguments(Sample minimum,
- Sample maximum,
- size_t bucket_count) const {
+bool SparseHistogram::HasConstructionArguments(
+ Sample expected_minimum,
+ Sample expected_maximum,
+ size_t expected_bucket_count) const {
// SparseHistogram never has min/max/bucket_count limit.
return false;
}
« no previous file with comments | « base/metrics/sparse_histogram.h ('k') | base/metrics/statistics_recorder_unittest.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698