Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(424)

Unified Diff: base/metrics/bucket_ranges_unittest.cc

Issue 17451016: [UMA] Remove redundant bucket_count variable from base::Histogram. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src
Patch Set: Rename variables to be clearer Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/metrics/bucket_ranges.h ('k') | base/metrics/histogram.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/metrics/bucket_ranges_unittest.cc
diff --git a/base/metrics/bucket_ranges_unittest.cc b/base/metrics/bucket_ranges_unittest.cc
index 424ff63ea1816b0f930277c54eb2d7e7aefd4507..fc0699c733792430faaae1dfe4ece1b592ac36d2 100644
--- a/base/metrics/bucket_ranges_unittest.cc
+++ b/base/metrics/bucket_ranges_unittest.cc
@@ -12,8 +12,9 @@ namespace {
TEST(BucketRangesTest, NormalSetup) {
BucketRanges ranges(5);
ASSERT_EQ(5u, ranges.size());
+ ASSERT_EQ(4u, ranges.bucket_count());
- for (int i = 0; i < 5; i++) {
+ for (int i = 0; i < 5; ++i) {
EXPECT_EQ(0, ranges.range(i));
}
EXPECT_EQ(0u, ranges.checksum());
« no previous file with comments | « base/metrics/bucket_ranges.h ('k') | base/metrics/histogram.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698