Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(499)

Unified Diff: utils/pub/version.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « utils/pub/validator/name.dart ('k') | utils/pub/version_solver.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: utils/pub/version.dart
diff --git a/utils/pub/version.dart b/utils/pub/version.dart
index 18e15a5f84a8f7deabdb0cf35a4e26aff37e3708..06c14fd4fb44c1de69968e8e0e18210fa0175909 100644
--- a/utils/pub/version.dart
+++ b/utils/pub/version.dart
@@ -192,7 +192,7 @@ class Version implements Comparable, VersionConstraint {
/// Splits a string of dot-delimited identifiers into their component parts.
/// Identifiers that are numeric are converted to numbers.
List _splitParts(String text) {
- return text.split('.').mappedBy((part) {
+ return text.split('.').map((part) {
try {
return int.parse(part);
} on FormatException catch (ex) {
« no previous file with comments | « utils/pub/validator/name.dart ('k') | utils/pub/version_solver.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698