Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(100)

Unified Diff: pkg/yaml/lib/yaml_map.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « pkg/yaml/lib/yaml.dart ('k') | runtime/lib/array.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/yaml/lib/yaml_map.dart
diff --git a/pkg/yaml/lib/yaml_map.dart b/pkg/yaml/lib/yaml_map.dart
index 65dd11994f04684fa039b946fd65d1d861455534..cbf18e5d21122871c44a9b732f447589e4834e85 100644
--- a/pkg/yaml/lib/yaml_map.dart
+++ b/pkg/yaml/lib/yaml_map.dart
@@ -29,7 +29,7 @@ class YamlMap implements Map {
void clear() => _map.clear();
void forEach(void f(key, value)) =>
_map.forEach((k, v) => f(_unwrapKey(k), v));
- Iterable get keys => _map.keys.mappedBy(_unwrapKey);
+ Iterable get keys => _map.keys.map(_unwrapKey);
Iterable get values => _map.values;
int get length => _map.length;
bool get isEmpty => _map.isEmpty;
« no previous file with comments | « pkg/yaml/lib/yaml.dart ('k') | runtime/lib/array.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698