Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1068)

Issue 10831047: Move BuildCallGetter/BuildCallSetter up in the call chain. (Closed)

Created:
8 years, 5 months ago by Sven Panne
Modified:
8 years, 5 months ago
Reviewers:
Michael Starzinger
CC:
v8-dev
Visibility:
Public.

Description

Move BuildCallGetter/BuildCallSetter up in the call chain. This is a refactoring-only CL and the third one in a series for enabling inlining of accessors. The goal of this CL is to move the builders for accessors to the places where we might be able to inline them later, i.e. the VisitFoo and HandleBar member functions of HGraphBuilder. Extracted duplicate code into LookupAccessorPair. Committed: https://code.google.com/p/v8/source/detail?r=12209

Patch Set 1 #

Total comments: 8

Patch Set 2 : Incorporated review comments. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+125 lines, -83 lines) Patch
M src/hydrogen.h View 1 4 chunks +34 lines, -24 lines 0 comments Download
M src/hydrogen.cc View 10 chunks +91 lines, -59 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Sven Panne
8 years, 5 months ago (2012-07-27 08:20:00 UTC) #1
Michael Starzinger
LGTM (with nits). https://chromiumcodereview.appspot.com/10831047/diff/1/src/hydrogen.h File src/hydrogen.h (right): https://chromiumcodereview.appspot.com/10831047/diff/1/src/hydrogen.h#newcode1091 src/hydrogen.h:1091: HLoadNamedField* BuildLoadNamedField(HValue* object, I know it's ...
8 years, 5 months ago (2012-07-27 09:19:23 UTC) #2
Sven Panne
8 years, 5 months ago (2012-07-27 09:42:40 UTC) #3
Landing...

http://codereview.chromium.org/10831047/diff/1/src/hydrogen.h
File src/hydrogen.h (right):

http://codereview.chromium.org/10831047/diff/1/src/hydrogen.h#newcode1091
src/hydrogen.h:1091: HLoadNamedField* BuildLoadNamedField(HValue* object,
On 2012/07/27 09:19:23, Michael Starzinger wrote:
> I know it's not part of your change, but can we move the declaration of this
> method into the block of property-related BuildFoo() methods?

Done.

http://codereview.chromium.org/10831047/diff/1/src/hydrogen.h#newcode1095
src/hydrogen.h:1095: HInstruction* BuildLoadNamedGeneric(HValue* object,
On 2012/07/27 09:19:23, Michael Starzinger wrote:
> Likewise.

Done.

http://codereview.chromium.org/10831047/diff/1/src/hydrogen.h#newcode1098
src/hydrogen.h:1098: HInstruction* BuildLoadKeyedGeneric(HValue* object, HValue*
key);
On 2012/07/27 09:19:23, Michael Starzinger wrote:
> Likewise.

Done.

http://codereview.chromium.org/10831047/diff/1/src/hydrogen.h#newcode1154
src/hydrogen.h:1154: bool LookupAccessorPair(Handle<Map> map,
On 2012/07/27 09:19:23, Michael Starzinger wrote:
> Can we have a short comment what this method does and about the semantics of
the
> return value. Also I would move it up a few lines in front of the block of
> property-related BuildFoo() methods.

Done.

Powered by Google App Engine
This is Rietveld 408576698