Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1150)

Unified Diff: runtime/vm/flow_graph_allocator.cc

Issue 10824308: Rename is_call to always_calls and contains_call to can_call. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | runtime/vm/flow_graph_compiler.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/vm/flow_graph_allocator.cc
diff --git a/runtime/vm/flow_graph_allocator.cc b/runtime/vm/flow_graph_allocator.cc
index 69fc5c619d249789208d38832a74a46306a61c7d..8b0dd6453901b3bef73ee1b6a864db1bdfb7941d 100644
--- a/runtime/vm/flow_graph_allocator.cc
+++ b/runtime/vm/flow_graph_allocator.cc
@@ -825,7 +825,7 @@ void FlowGraphAllocator::ProcessOneInstruction(BlockEntryInstr* block,
}
// Block all allocatable registers for calls and record the stack bitmap.
- if (locs->is_call()) {
+ if (locs->always_calls()) {
// Expected shape of live range:
//
// i i'
@@ -854,7 +854,7 @@ void FlowGraphAllocator::ProcessOneInstruction(BlockEntryInstr* block,
#endif
}
- if (locs->contains_call()) {
+ if (locs->can_call()) {
safepoints_.Add(current);
}
« no previous file with comments | « no previous file | runtime/vm/flow_graph_compiler.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698