Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(925)

Unified Diff: runtime/vm/flow_graph_compiler.cc

Issue 10824308: Rename is_call to always_calls and contains_call to can_call. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « runtime/vm/flow_graph_allocator.cc ('k') | runtime/vm/flow_graph_compiler_ia32.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/vm/flow_graph_compiler.cc
diff --git a/runtime/vm/flow_graph_compiler.cc b/runtime/vm/flow_graph_compiler.cc
index ea64413883067b5b61a5ef0e4ec04ea03728b0d4..df13446e1f0223bf271eaacc929f9d4bce37ef5d 100644
--- a/runtime/vm/flow_graph_compiler.cc
+++ b/runtime/vm/flow_graph_compiler.cc
@@ -707,7 +707,7 @@ void FrameRegisterAllocator::AllocateRegisters(Instruction* instr) {
// If this instruction is call spill everything that was not consumed by
// input locations.
- if (locs->contains_call() || instr->IsBranch() || instr->IsGoto()) {
+ if (locs->can_call() || instr->IsBranch() || instr->IsGoto()) {
Spill();
}
« no previous file with comments | « runtime/vm/flow_graph_allocator.cc ('k') | runtime/vm/flow_graph_compiler_ia32.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698