Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(187)

Issue 10832410: Give a length field to stack bitmaps. (Closed)

Created:
8 years, 4 months ago by Kevin Millikin (Google)
Modified:
8 years, 4 months ago
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Give a length field to stack bitmaps. The bitmaps describing the stack have an explicit length field. It is now an assertion failure to read bits outside the length --- they are no longer assumed to be false. Also remove an unused method and simplify the implementation of BitmapBuilder by removing an embedded member that was always referred to via a pointer. R=vegorov@google.com BUG= Committed: https://code.google.com/p/dart/source/detail?r=11138

Patch Set 1 #

Total comments: 4

Patch Set 2 : Incorporated review comments. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+143 lines, -82 lines) Patch
M runtime/vm/bitmap.h View 1 3 chunks +24 lines, -14 lines 0 comments Download
M runtime/vm/bitmap.cc View 1 2 chunks +53 lines, -44 lines 0 comments Download
M runtime/vm/bitmap_test.cc View 4 chunks +36 lines, -12 lines 0 comments Download
M runtime/vm/code_descriptors.cc View 1 chunk +2 lines, -1 line 0 comments Download
M runtime/vm/code_descriptors_test.cc View 4 chunks +20 lines, -0 lines 0 comments Download
M runtime/vm/object.h View 2 chunks +3 lines, -4 lines 0 comments Download
M runtime/vm/object.cc View 1 2 chunks +5 lines, -7 lines 0 comments Download

Messages

Total messages: 4 (0 generated)
Kevin Millikin (Google)
8 years, 4 months ago (2012-08-21 11:47:36 UTC) #1
Kevin Millikin (Google)
http://codereview.chromium.org/10832410/diff/1/runtime/vm/code_descriptors.cc File runtime/vm/code_descriptors.cc (right): http://codereview.chromium.org/10832410/diff/1/runtime/vm/code_descriptors.cc#newcode57 runtime/vm/code_descriptors.cc:57: bitmap->SetLength(entry_length_); Long-term, we will not set the length here ...
8 years, 4 months ago (2012-08-21 13:24:07 UTC) #2
Vyacheslav Egorov (Google)
lgtm https://chromiumcodereview.appspot.com/10832410/diff/1/runtime/vm/bitmap.h File runtime/vm/bitmap.h (right): https://chromiumcodereview.appspot.com/10832410/diff/1/runtime/vm/bitmap.h#newcode63 runtime/vm/bitmap.h:63: intptr_t size_in_bytes_; I would rename size_in_bytes_ and bit_list_ ...
8 years, 4 months ago (2012-08-22 11:49:40 UTC) #3
Kevin Millikin (Google)
8 years, 4 months ago (2012-08-22 11:56:27 UTC) #4
https://chromiumcodereview.appspot.com/10832410/diff/1/runtime/vm/bitmap.h
File runtime/vm/bitmap.h (right):

https://chromiumcodereview.appspot.com/10832410/diff/1/runtime/vm/bitmap.h#ne...
runtime/vm/bitmap.h:63: intptr_t size_in_bytes_;
On 2012/08/22 11:49:40, Vyacheslav Egorov (Google) wrote:
> I would rename size_in_bytes_ and bit_list_ in such a way that connection
> between them would become apparent. 
> 
> I would also add a comment here that reading bits outside of backing store is
> allowed and they are assumed to be false.

OK.  (bit_list_, size_in_bytes_) => (data_, data_size_in_bytes_).

Powered by Google App Engine
This is Rietveld 408576698