Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(368)

Issue 9241010: Fix corner-case in heap size estimation. (Closed)

Created:
8 years, 11 months ago by Michael Starzinger
Modified:
8 years, 11 months ago
CC:
v8-dev
Visibility:
Public.

Description

Fix corner-case in heap size estimation. Empty but unswept pages could cause the unswept_free_bytes counter to to be off in case heap gets shrunk and page gets released before it was swept properly. R=vegorov@chromium.org BUG=v8:1893 Committed: https://code.google.com/p/v8/source/detail?r=10421

Patch Set 1 #

Total comments: 2

Patch Set 2 : Addressed comments by Vyacheslav Egorov. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+14 lines, -3 lines) Patch
M src/mark-compact.cc View 1 2 chunks +4 lines, -1 line 0 comments Download
M src/spaces.h View 1 1 chunk +7 lines, -1 line 0 comments Download
M src/spaces.cc View 1 2 chunks +3 lines, -1 line 0 comments Download

Messages

Total messages: 3 (0 generated)
Michael Starzinger
8 years, 11 months ago (2012-01-17 13:43:08 UTC) #1
Vyacheslav Egorov (Chromium)
lgtm with a better name for Mark/Unmark routines :-) http://codereview.chromium.org/9241010/diff/1/src/mark-compact.cc File src/mark-compact.cc (right): http://codereview.chromium.org/9241010/diff/1/src/mark-compact.cc#newcode3636 src/mark-compact.cc:3636: ...
8 years, 11 months ago (2012-01-17 13:49:37 UTC) #2
Michael Starzinger
8 years, 11 months ago (2012-01-17 14:09:38 UTC) #3
Added new patch set. Landed.

http://codereview.chromium.org/9241010/diff/1/src/mark-compact.cc
File src/mark-compact.cc (right):

http://codereview.chromium.org/9241010/diff/1/src/mark-compact.cc#newcode3636
src/mark-compact.cc:3636: space->MarkPageForLazySweeping(p);
On 2012/01/17 13:49:37, Vyacheslav Egorov wrote:
> this is pretty confusing. we are both marking it for lazy sweepign and
releasing
> it immediately.
> 
> maybe rename MarkPageForLazySweeping into something else?

Done. As discussed offline we chose IncreaseUnsweptFreeBytes  (and the Decrease
counterpart) to be a suitable name here.

Powered by Google App Engine
This is Rietveld 408576698