Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(413)

Unified Diff: pkg/compiler/lib/src/parser/node_listener.dart

Issue 2982033002: Rename FunctionDeclaration to LocalFunctionDeclaration. (Closed)
Patch Set: Documentation tweak. Created 3 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/compiler/lib/src/parser/node_listener.dart
diff --git a/pkg/compiler/lib/src/parser/node_listener.dart b/pkg/compiler/lib/src/parser/node_listener.dart
index 29e1000dc855f82eb4f5b821f82d63cb97097e01..c44cd7d81694af861aacc9492f79205e08a30cf1 100644
--- a/pkg/compiler/lib/src/parser/node_listener.dart
+++ b/pkg/compiler/lib/src/parser/node_listener.dart
@@ -508,7 +508,7 @@ class NodeListener extends ElementListener {
}
@override
- void endFunctionDeclaration(Token endToken) {
+ void endLocalFunctionDeclaration(Token endToken) {
Statement body = popNode();
AsyncModifier asyncModifier = popNode();
NodeList initializers = popNode();
« no previous file with comments | « pkg/analyzer/test/generated/parser_fasta_listener.dart ('k') | pkg/front_end/lib/src/fasta/kernel/body_builder.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698