Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(818)

Unified Diff: src/heap/heap.h

Issue 2433273002: [wasm] Avoid double-serializing the wire bytes (Closed)
Patch Set: removed unrelated changes Created 4 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/api.cc ('k') | src/runtime/runtime.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/heap/heap.h
diff --git a/src/heap/heap.h b/src/heap/heap.h
index 84bbe89725e88dc04268a01c9edc88ef27ce3552..eee7d28a6959a8631de5a535e4acf88173916df5 100644
--- a/src/heap/heap.h
+++ b/src/heap/heap.h
@@ -1442,6 +1442,10 @@ class Heap {
// ArrayBuffer tracking. =====================================================
// ===========================================================================
+ // TODO(gc): API usability: encapsulate mutation of JSArrayBuffer::is_external
+ // in the registration/unregistration APIs. Consider dropping the "New" from
+ // "RegisterNewArrayBuffer" because one can re-register a previously
+ // unregistered buffer, too, and the name is confusing.
void RegisterNewArrayBuffer(JSArrayBuffer* buffer);
void UnregisterArrayBuffer(JSArrayBuffer* buffer);
« no previous file with comments | « src/api.cc ('k') | src/runtime/runtime.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698