DescriptionRename SkDrawCommand subclasses
SkDrawCommand subclass names are too generic and likely to clash in the default namespace.
This makes the header unusable in Chrome - for example, on Mac builders:
../../third_party/skia/src/utils/debugger/SkDrawCommand.h:251:7: error: redefinition of 'Comment'
class Comment : public SkDrawCommand {
^
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/AIFF.h:192:8: note: previous definition is here
struct Comment {
This CL renames SkDrawCommand subclasses using the following pattern: "${cmd}" -> "Sk${cmd}Command".
R=robertphillips@google.com,reed@google.com
Committed: http://code.google.com/p/skia/source/detail?r=9667
Patch Set 1 #Patch Set 2 : SkDrawCommand subclasses rename only. #
Total comments: 17
Patch Set 3 : Updated per review. #
Messages
Total messages: 7 (0 generated)
|