Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(244)

Unified Diff: content/common/shared_memory_seqlock_buffer.h

Issue 14678012: Implement the content/renderer and content/browser part of the Device Motion API. (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: fixed Darin's comments, added generic reader + rebased Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/common/shared_memory_seqlock_buffer.h
diff --git a/content/common/shared_memory_seqlock_buffer.h b/content/common/shared_memory_seqlock_buffer.h
new file mode 100644
index 0000000000000000000000000000000000000000..e6ba187715e9a1de179a4318b3ed553d2c0cc6e2
--- /dev/null
+++ b/content/common/shared_memory_seqlock_buffer.h
@@ -0,0 +1,30 @@
+// Copyright (c) 2013 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+#ifndef CONTENT_COMMON_SHARED_MEMORY_SEQLOCK_BUFFER_H_
+#define CONTENT_COMMON_SHARED_MEMORY_SEQLOCK_BUFFER_H_
+
+#include "content/common/gamepad_seqlock.h"
+
+namespace content {
+
+// This structure is stored in shared memory that's shared between the browser
+// which does the hardware polling, and the consumers of the device motion
+// data, i.e. the renderers. The performance characteristics are that
+// we want low latency (so would like to avoid explicit communication via IPC
+// between producer and consumer) and relatively large data size.
+//
+// Writer and reader operate on the same buffer assuming contention is low, and
+// contention is detected by using the associated SeqLock.
+
+template<class Data>
+struct SharedMemorySeqLockBuffer {
+ GamepadSeqLock sequence;
darin (slow to review) 2013/06/17 20:23:44 nit: seems like GamepadSeqLock needs to be renamed
timvolodine 2013/06/18 16:44:31 Done. renamed to OneWriterSeqLock.
+ Data buffer;
darin (slow to review) 2013/06/17 20:23:44 nit: maybe "buffer" should be named "data" to matc
timvolodine 2013/06/18 16:44:31 absolutely agree, Done.
+ bool is_ready_for_read;
+};
+
+} // namespace content
+
+#endif // CONTENT_COMMON_SHARED_MEMORY_SEQLOCK_BUFFER_H_

Powered by Google App Engine
This is Rietveld 408576698