Index: src/full-codegen.h |
diff --git a/src/full-codegen.h b/src/full-codegen.h |
index c4f3fcc722b3252ce6970c87abb02b3a8a4423f7..96855bd5eb1b70ff37a7f37fae48db93f98330d8 100644 |
--- a/src/full-codegen.h |
+++ b/src/full-codegen.h |
@@ -92,7 +92,7 @@ class FullCodeGenerator: public AstVisitor { |
bailout_entries_(info->HasDeoptimizationSupport() |
? info->function()->ast_node_count() : 0, |
info->zone()), |
- stack_checks_(2, info->zone()), // There's always at least one. |
+ back_edges_(2, info->zone()), // There's always at least one. |
Jakob Kummerow
2013/04/09 17:23:25
nit: the comment is outdated, just remove it. (The
Yang
2013/04/10 08:08:30
Done.
|
type_feedback_cells_(info->HasDeoptimizationSupport() |
? info->function()->ast_node_count() : 0, |
info->zone()), |
@@ -461,7 +461,7 @@ class FullCodeGenerator: public AstVisitor { |
void RecordBackEdge(BailoutId osr_ast_id); |
// Emit a table of stack check ids and pcs into the code stream. Return |
// the offset of the start of the table. |
- unsigned EmitStackCheckTable(); |
+ unsigned EmitBackEdgeTable(); |
void EmitProfilingCounterDecrement(int delta); |
void EmitProfilingCounterReset(); |
@@ -624,6 +624,12 @@ class FullCodeGenerator: public AstVisitor { |
unsigned pc_and_state; |
}; |
+ struct BackEdgeEntry { |
+ BailoutId id; |
+ unsigned pc; |
+ uint8_t loop_depth; |
+ }; |
+ |
struct TypeFeedbackCellEntry { |
TypeFeedbackId ast_id; |
Handle<JSGlobalPropertyCell> cell; |
@@ -820,7 +826,7 @@ class FullCodeGenerator: public AstVisitor { |
GrowableBitVector prepared_bailout_ids_; |
// TODO(svenpanne) Rename this to something like back_edges_ and rename |
Jakob Kummerow
2013/04/09 17:23:25
You can remove this TODO, since it describes exact
Yang
2013/04/10 08:08:30
Done.
|
// related functions accordingly. |
- ZoneList<BailoutEntry> stack_checks_; |
+ ZoneList<BackEdgeEntry> back_edges_; |
ZoneList<TypeFeedbackCellEntry> type_feedback_cells_; |
int ic_total_count_; |
Handle<FixedArray> handler_table_; |