Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(842)

Unified Diff: utils/pub/validator/lib.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « utils/pub/validator/directory.dart ('k') | utils/pub/validator/license.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: utils/pub/validator/lib.dart
diff --git a/utils/pub/validator/lib.dart b/utils/pub/validator/lib.dart
index e6798476f191065fc7e92810b6bc3cf538dc85f6..faee7290231abda4caa52fa2be39bc1ab66c36b0 100644
--- a/utils/pub/validator/lib.dart
+++ b/utils/pub/validator/lib.dart
@@ -31,7 +31,7 @@ class LibValidator extends Validator {
}
return listDir(libDir).then((files) {
- files = files.mappedBy((file) => relativeTo(file, libDir)).toList();
+ files = files.map((file) => relativeTo(file, libDir)).toList();
if (files.isEmpty) {
errors.add('You must have a non-empty "lib" directory.\n'
"Without that, users cannot import any code from your package.");
« no previous file with comments | « utils/pub/validator/directory.dart ('k') | utils/pub/validator/license.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698