Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(74)

Unified Diff: sdk/lib/_internal/compiler/implementation/lib/constant_map.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
diff --git a/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart b/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
index 625e0ed7cf8e3e744387518d9195d406952954d8..75446c7b91e83c20ae4d733d69f0966924346cdb 100644
--- a/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
+++ b/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
@@ -35,8 +35,7 @@ class ConstantMap<V> implements Map<String, V> {
}
Iterable<V> get values {
- // TODO(floitsch): don't wrap the map twice.
- return keys.mappedBy((String key) => this[key]);
+ return _keys.map((String key) => this[key]);
}
bool get isEmpty => length == 0;

Powered by Google App Engine
This is Rietveld 408576698