Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(394)

Unified Diff: sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart
diff --git a/sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart b/sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart
index c4ff47f0fabecd557b8037f8c9b1f4366e409bfd..06d5d01a16f8c2d60f9034a342ed5ed39125ced2 100644
--- a/sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart
+++ b/sdk/lib/_internal/compiler/implementation/js_backend/emitter_no_eval.dart
@@ -80,10 +80,10 @@ $lazyInitializerLogic
new js.VariableDeclaration(mangledName),
new js.Fun(
fieldNames
- .mappedBy((fieldName) => new js.Parameter(fieldName))
+ .map((fieldName) => new js.Parameter(fieldName))
.toList(),
new js.Block(
- fieldNames.mappedBy((fieldName) =>
+ fieldNames.map((fieldName) =>
new js.ExpressionStatement(
new js.Assignment(
new js.This().dot(fieldName),

Powered by Google App Engine
This is Rietveld 408576698