Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2234)

Unified Diff: sdk/lib/_internal/compiler/implementation/js/nodes.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/js/nodes.dart
diff --git a/sdk/lib/_internal/compiler/implementation/js/nodes.dart b/sdk/lib/_internal/compiler/implementation/js/nodes.dart
index 8a4960a6faba19505f37b987397fc26112f91224..148547e5076023b6ae6f05611a77d55b6c895b78 100644
--- a/sdk/lib/_internal/compiler/implementation/js/nodes.dart
+++ b/sdk/lib/_internal/compiler/implementation/js/nodes.dart
@@ -791,7 +791,7 @@ class ArrayInitializer extends Expression {
static List<ArrayElement> _convert(List<Expression> expressions) {
int index = 0;
- return expressions.mappedBy(
+ return expressions.map(
(expression) => new ArrayElement(index++, expression))
.toList();
}
@@ -896,8 +896,7 @@ Call call(Expression target, List<Expression> arguments) {
}
Fun fun(List<String> parameterNames, Block body) {
- return new Fun(parameterNames.mappedBy((n) => new Parameter(n)).toList(),
- body);
+ return new Fun(parameterNames.map((n) => new Parameter(n)).toList(), body);
}
Assignment assign(Expression leftHandSide, Expression value) {

Powered by Google App Engine
This is Rietveld 408576698