Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(265)

Unified Diff: pkg/http/lib/src/utils.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Undo change to test-script. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/http/lib/src/utils.dart
diff --git a/pkg/http/lib/src/utils.dart b/pkg/http/lib/src/utils.dart
index e1b952e8aecbd8a232be3c5cfe0752446d44e60f..c61733ef0c6f1b342ffa7eca0410443c1a8d056e 100644
--- a/pkg/http/lib/src/utils.dart
+++ b/pkg/http/lib/src/utils.dart
@@ -38,7 +38,7 @@ String mapToQuery(Map<String, String> map) {
var pairs = <List<String>>[];
map.forEach((key, value) =>
pairs.add([encodeUriComponent(key), encodeUriComponent(value)]));
- return Strings.join(pairs.mappedBy((pair) => "${pair[0]}=${pair[1]}"), "&");
+ return Strings.join(pairs.map((pair) => "${pair[0]}=${pair[1]}"), "&");
}
/// Adds all key/value pairs from [source] to [destination], overwriting any

Powered by Google App Engine
This is Rietveld 408576698