Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(654)

Unified Diff: components/guest_view/renderer/guest_view_container.h

Issue 1162053003: Move BrowserPluginDelegate's lifetime mgmt out of content/ (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Clean up for review. Created 5 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/guest_view/renderer/guest_view_container.h
diff --git a/components/guest_view/renderer/guest_view_container.h b/components/guest_view/renderer/guest_view_container.h
index 50b05cb886ab97832a4ed308c1c27c2ffff01c50..cf7b94e4e8852f2256478c1b2be6f90fd6e8891f 100644
--- a/components/guest_view/renderer/guest_view_container.h
+++ b/components/guest_view/renderer/guest_view_container.h
@@ -43,6 +43,10 @@ class GuestViewContainer : public content::BrowserPluginDelegate {
// Called to perform actions when a GuestViewContainer gets a geometry.
virtual void OnReady() {}
+ // Called to perform actions when a GuestViewContainer is about to be
+ // destroyed.
+ virtual void OnDestroy() {}
+
private:
class RenderFrameLifetimeObserver;
friend class RenderFrameLifetimeObserver;
@@ -58,6 +62,7 @@ class GuestViewContainer : public content::BrowserPluginDelegate {
// BrowserPluginDelegate implementation.
void Ready() final;
void SetElementInstanceID(int element_instance_id) final;
+ void WillDestroy() final;
lazyboy 2015/06/05 16:56:55 The chosen name here is ambiguous, the name should
int element_instance_id_;
content::RenderFrame* render_frame_;

Powered by Google App Engine
This is Rietveld 408576698