Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(165)

Issue 10959011: Allow partial scanning of large arrays in order to avoid (Closed)

Created:
8 years, 3 months ago by Erik Corry
Modified:
8 years, 3 months ago
Reviewers:
Michael Starzinger
CC:
v8-dev
Visibility:
Public.

Description

Allow partial scanning of large arrays in order to avoid mark stack overflow. Committed: https://code.google.com/p/v8/source/detail?r=12609

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+301 lines, -72 lines) Patch
M src/incremental-marking.h View 1 chunk +2 lines, -0 lines 0 comments Download
M src/incremental-marking.cc View 5 chunks +155 lines, -57 lines 0 comments Download
M src/mark-compact.h View 2 chunks +33 lines, -0 lines 0 comments Download
M src/mark-compact.cc View 5 chunks +77 lines, -10 lines 2 comments Download
M src/spaces.h View 4 chunks +33 lines, -2 lines 0 comments Download
M src/spaces.cc View 1 chunk +1 line, -3 lines 0 comments Download

Messages

Total messages: 2 (0 generated)
Erik Corry
8 years, 3 months ago (2012-09-20 10:44:42 UTC) #1
Michael Starzinger
8 years, 3 months ago (2012-09-20 13:29:48 UTC) #2
Two general questions on the incremental marking part of this CL:

1) Would it be possible to share the code between incremental and
non-incremental marking?
2) Would it be possible to use static visitors for incremental marking?

https://codereview.chromium.org/10959011/diff/1/src/mark-compact.cc
File src/mark-compact.cc (right):

https://codereview.chromium.org/10959011/diff/1/src/mark-compact.cc#newcode2181
src/mark-compact.cc:2181: } while (!marking_deque_.IsEmpty());
Instead of adding yet another loop we could just reuse the outer one that was
added for the WeakMaps fix-point iteration.

https://codereview.chromium.org/10959011/diff/1/src/mark-compact.cc#newcode2190
src/mark-compact.cc:2190: void
MarkCompactCollector::FillMarkingDequeFromLargePostponedArrays() {
How about naming this "ProcessLargePostponedArrays()"

Powered by Google App Engine
This is Rietveld 408576698