Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(123)

Unified Diff: tests/compiler/dart2js/type_checker_test.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: tests/compiler/dart2js/type_checker_test.dart
diff --git a/tests/compiler/dart2js/type_checker_test.dart b/tests/compiler/dart2js/type_checker_test.dart
index 1d5b31f1e5e9d76266e184468cad1e3bcd2d3806..2ca45f7aa87ccd1d29d479c74be613e690864e48 100644
--- a/tests/compiler/dart2js/type_checker_test.dart
+++ b/tests/compiler/dart2js/type_checker_test.dart
@@ -353,10 +353,10 @@ testThis() {
testFunctionSubtyping() {
// Checks that the type (in1 -> out1) is a subtype of (in2 -> out2).
- bool isSubtype(List<Type> in1, Type out1, List<Type> in2, Type out2) {
+ bool isSubtype(List<DartType> in1, Type out1, List<Type> in2, Type out2) {
return compiler.types.isSubtype(
- new FunctionType(out1, new Link<Type>.fromList(in1), null),
- new FunctionType(out2, new Link<Type>.fromList(in2), null));
+ new FunctionType(out1, new Link<DartType>.fromList(in1), null),
+ new FunctionType(out2, new Link<DartType>.fromList(in2), null));
}
Expect.isTrue(isSubtype([], intType, [], intType));
Expect.isTrue(isSubtype([], intType, [], objectType));

Powered by Google App Engine
This is Rietveld 408576698