Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(550)

Unified Diff: lib/compiler/implementation/ssa/nodes.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/ssa/nodes.dart
diff --git a/lib/compiler/implementation/ssa/nodes.dart b/lib/compiler/implementation/ssa/nodes.dart
index 82238840b335395ef15bd8252c4a8c9bb23f8915..8ba3130a938604ad41f6627f0226bb59e60e4fff 100644
--- a/lib/compiler/implementation/ssa/nodes.dart
+++ b/lib/compiler/implementation/ssa/nodes.dart
@@ -759,7 +759,7 @@ class HInstruction implements Hashable {
// Other flags.
static const int FLAG_USE_GVN = FLAG_DEPENDS_ON_SOMETHING + 1;
- // Type codes.
+ // DartType codes.
kasperl 2012/08/30 14:11:27 Remove Dart again.
static const int UNDEFINED_TYPECODE = -1;
static const int BOOLIFY_TYPECODE = 0;
static const int TYPE_GUARD_TYPECODE = 1;
@@ -2402,7 +2402,7 @@ class HIndexAssign extends HInvokeStatic {
}
class HIs extends HInstruction {
- final Type typeExpression;
+ final DartType typeExpression;
final bool nullOk;
HIs.withTypeInfoCall(this.typeExpression, HInstruction expression,

Powered by Google App Engine
This is Rietveld 408576698