Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(515)

Unified Diff: lib/compiler/implementation/ssa/bailout.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/ssa/bailout.dart
diff --git a/lib/compiler/implementation/ssa/bailout.dart b/lib/compiler/implementation/ssa/bailout.dart
index a1e537731b12aa6676d118be2373bbbcca89ca9d..789b98e018d4af9c7edf94dbd6230637b90bf535 100644
--- a/lib/compiler/implementation/ssa/bailout.dart
+++ b/lib/compiler/implementation/ssa/bailout.dart
@@ -117,8 +117,8 @@ class SsaTypeGuardInserter extends HGraphVisitor implements OptimizationPhase {
// annotation that disagrees with the speculated type.
Element source = instruction.sourceElement;
if (source !== null) {
- Type sourceType = source.computeType(compiler);
- Type speculatedType = speculativeType.computeType(compiler);
+ DartType sourceType = source.computeType(compiler);
+ DartType speculatedType = speculativeType.computeType(compiler);
if (speculatedType !== null
&& !compiler.types.isAssignable(speculatedType, sourceType)) {
return false;

Powered by Google App Engine
This is Rietveld 408576698