Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(597)

Unified Diff: lib/compiler/implementation/js_backend/partial_type_tree.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/js_backend/partial_type_tree.dart
diff --git a/lib/compiler/implementation/js_backend/partial_type_tree.dart b/lib/compiler/implementation/js_backend/partial_type_tree.dart
index 7d4afe05cd410962ec6987a87ca42a7ea43cbee4..19f2841fa7bd819736dd9b57669cd6daf27c54d8 100644
--- a/lib/compiler/implementation/js_backend/partial_type_tree.dart
+++ b/lib/compiler/implementation/js_backend/partial_type_tree.dart
@@ -13,7 +13,7 @@ class PartialTypeTree {
// TODO(kasperl): Move this to the Selector class?
ClassElement selectorType(Selector selector) {
- Type type = selector.receiverType;
+ DartType type = selector.receiverType;
return (type !== null) ? type.element : compiler.objectClass;
}

Powered by Google App Engine
This is Rietveld 408576698