Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(481)

Unified Diff: lib/compiler/implementation/enqueue.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/enqueue.dart
diff --git a/lib/compiler/implementation/enqueue.dart b/lib/compiler/implementation/enqueue.dart
index 1172b5f3bdb4a3b9802cc6073eeb008beea43d56..c9a2b23144dd0c2243f2d832467caaf1cf4d310a 100644
--- a/lib/compiler/implementation/enqueue.dart
+++ b/lib/compiler/implementation/enqueue.dart
@@ -215,7 +215,7 @@ class Enqueuer {
// supertypes.
cls.ensureResolved(compiler);
- for (Link<Type> supertypes = cls.allSupertypesAndSelf;
+ for (Link<DartType> supertypes = cls.allSupertypesAndSelf;
!supertypes.isEmpty(); supertypes = supertypes.tail) {
cls = supertypes.head.element;
if (seenClasses.contains(cls)) continue;
@@ -314,7 +314,7 @@ class Enqueuer {
void registerFieldGetter(SourceString getterName,
LibraryElement library,
- Type type) {
+ DartType type) {
task.measure(() {
Selector getter = new Selector.getter(getterName, library);
registerNewSelector(getterName,
@@ -325,7 +325,7 @@ class Enqueuer {
void registerFieldSetter(SourceString setterName,
LibraryElement library,
- Type type) {
+ DartType type) {
task.measure(() {
Selector setter = new Selector.setter(setterName, library);
registerNewSelector(setterName,

Powered by Google App Engine
This is Rietveld 408576698