Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(507)

Unified Diff: lib/compiler/implementation/compiler.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/compiler.dart
diff --git a/lib/compiler/implementation/compiler.dart b/lib/compiler/implementation/compiler.dart
index 23797006b1f4a05d250d98e8961a7876c762c991..be92fab12d9e63599dd614fe23a16bc92785b847 100644
--- a/lib/compiler/implementation/compiler.dart
+++ b/lib/compiler/implementation/compiler.dart
@@ -717,7 +717,7 @@ class Compiler implements DiagnosticListener {
enqueuer.codegen.registerInstantiatedClass(cls);
}
- Type resolveTypeAnnotation(Element element, TypeAnnotation annotation) {
+ DartType resolveTypeAnnotation(Element element, TypeAnnotation annotation) {
return resolver.resolveTypeAnnotation(element, annotation);
}

Powered by Google App Engine
This is Rietveld 408576698