Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(957)

Unified Diff: lib/compiler/implementation/closure.dart

Issue 10911007: Rename Type to DartType to avoid conflicts with the class Type in the core library. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/closure.dart
diff --git a/lib/compiler/implementation/closure.dart b/lib/compiler/implementation/closure.dart
index 6782e1585c1404e3071146afd4283ef39634e8f7..f278e6ba8ba7b5118f37e1dcb0d93a0f15ef6f9b 100644
--- a/lib/compiler/implementation/closure.dart
+++ b/lib/compiler/implementation/closure.dart
@@ -70,8 +70,8 @@ class ClosureClassElement extends ClassElement {
STATE_DONE) {
compiler.closureClass.ensureResolved(compiler);
supertype = compiler.closureClass.computeType(compiler);
- interfaces = const EmptyLink<Type>();
- allSupertypes = new Link<Type>(supertype);
+ interfaces = const EmptyLink<DartType>();
+ allSupertypes = new Link<DartType>(supertype);
}
bool isClosure() => true;
}
« no previous file with comments | « no previous file | lib/compiler/implementation/compile_time_constants.dart » ('j') | lib/compiler/implementation/ssa/codegen.dart » ('J')

Powered by Google App Engine
This is Rietveld 408576698