Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(372)

Unified Diff: chrome/browser/chromeos/gdata/drive_service_interface.h

Issue 10828385: Rename DocumentsServiceInterface to DriveServiceInterface. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src
Patch Set: Fix unnecessary includes. Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chrome/browser/chromeos/gdata/drive_service_interface.h
diff --git a/chrome/browser/chromeos/gdata/documents_service_interface.h b/chrome/browser/chromeos/gdata/drive_service_interface.h
similarity index 96%
rename from chrome/browser/chromeos/gdata/documents_service_interface.h
rename to chrome/browser/chromeos/gdata/drive_service_interface.h
index f576d4cf47cfe7c063202f6c70a7363476a37613..7d5cc1e7952369ff86008d20057db422f193452c 100644
--- a/chrome/browser/chromeos/gdata/documents_service_interface.h
+++ b/chrome/browser/chromeos/gdata/drive_service_interface.h
@@ -2,12 +2,13 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#ifndef CHROME_BROWSER_CHROMEOS_GDATA_DOCUMENTS_SERVICE_INTERFACE_H_
-#define CHROME_BROWSER_CHROMEOS_GDATA_DOCUMENTS_SERVICE_INTERFACE_H_
+#ifndef CHROME_BROWSER_CHROMEOS_GDATA_DRIVE_SERVICE_INTERFACE_H_
+#define CHROME_BROWSER_CHROMEOS_GDATA_DRIVE_SERVICE_INTERFACE_H_
#include "chrome/browser/chromeos/gdata/operations_base.h"
// TODO(kochi): Further split gdata_operations.h and include only necessary
// headers. http://crbug.com/141469
+// DownloadActionCallback/InitiateUploadParams/ResulmeUploadParams
#include "chrome/browser/chromeos/gdata/gdata_operations.h"
class Profile;
@@ -46,10 +47,9 @@ enum DocumentExportFormat {
//
// TODO(zel,benchan): Make the terminology/naming convention (e.g. file vs
// document vs resource, directory vs collection) more consistent and precise.
-// TODO(kochi): Rename this to DriveServiceInterface. http://crbug.com/143661.
-class DocumentsServiceInterface {
+class DriveServiceInterface {
public:
- virtual ~DocumentsServiceInterface() {}
+ virtual ~DriveServiceInterface() {}
// Common service:
@@ -198,4 +198,4 @@ class DocumentsServiceInterface {
} // namespace gdata
-#endif // CHROME_BROWSER_CHROMEOS_GDATA_DOCUMENTS_SERVICE_INTERFACE_H_
+#endif // CHROME_BROWSER_CHROMEOS_GDATA_DRIVE_SERVICE_INTERFACE_H_
« no previous file with comments | « chrome/browser/chromeos/gdata/drive_api_service.h ('k') | chrome/browser/chromeos/gdata/drive_task_executor.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698