Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1076)

Unified Diff: runtime/vm/flow_graph_optimizer.cc

Issue 10824308: Rename is_call to always_calls and contains_call to can_call. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 8 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « runtime/vm/flow_graph_compiler_x64.cc ('k') | runtime/vm/locations.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/vm/flow_graph_optimizer.cc
diff --git a/runtime/vm/flow_graph_optimizer.cc b/runtime/vm/flow_graph_optimizer.cc
index 412fec427af18db078321731cd31443b7040f364..c93cb1bd17b802194717058f35c58e63037321e3 100644
--- a/runtime/vm/flow_graph_optimizer.cc
+++ b/runtime/vm/flow_graph_optimizer.cc
@@ -716,7 +716,7 @@ void FlowGraphAnalyzer::Analyze() {
BlockEntryInstr* entry = blocks_[i];
for (ForwardInstructionIterator it(entry); !it.Done(); it.Advance()) {
LocationSummary* locs = it.Current()->locs();
- if ((locs != NULL) && locs->contains_call()) {
+ if ((locs != NULL) && locs->can_call()) {
is_leaf_ = false;
return;
}
« no previous file with comments | « runtime/vm/flow_graph_compiler_x64.cc ('k') | runtime/vm/locations.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698