Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(565)

Unified Diff: vm/raw_object.h

Issue 10808064: Rename some of the enum definitions inside classes to avoid conflict with the ObjectKind enum. (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/runtime/
Patch Set: Created 8 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « vm/parser_test.cc ('k') | vm/resolver_test.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: vm/raw_object.h
===================================================================
--- vm/raw_object.h (revision 9791)
+++ vm/raw_object.h (working copy)
@@ -539,7 +539,7 @@
class RawFunction : public RawObject {
public:
enum Kind {
- kFunction,
+ kRegularFunction,
kClosureFunction,
kSignatureFunction, // represents a signature only without actual code.
kGetterFunction, // represents getter functions e.g: get foo() { .. }.
@@ -641,9 +641,9 @@
class RawScript : public RawObject {
public:
enum Kind {
- kScript = 0,
- kLibrary,
- kSource
+ kScriptTag = 0,
+ kLibraryTag,
+ kSourceTag
};
private:
« no previous file with comments | « vm/parser_test.cc ('k') | vm/resolver_test.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698