Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(786)

Issue 10703103: Fix unhandlified code calling Harmony Proxy traps. (Closed)

Created:
8 years, 5 months ago by Michael Starzinger
Modified:
8 years, 5 months ago
Reviewers:
rossberg
CC:
v8-dev
Visibility:
Public.

Description

Fix unhandlified code calling Harmony Proxy traps. R=rossberg@chromium.org BUG=v8:2219 TEST=mjsunit/regress/regress-2219 Committed: https://code.google.com/p/v8/source/detail?r=12001

Patch Set 1 #

Total comments: 4

Patch Set 2 : Addressed comments by Andreas Rossberg. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+53 lines, -47 lines) Patch
M src/objects.cc View 1 2 chunks +49 lines, -39 lines 0 comments Download
A + test/mjsunit/regress/regress-2219.js View 1 chunk +4 lines, -8 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Michael Starzinger
8 years, 5 months ago (2012-07-06 08:46:51 UTC) #1
rossberg
LGTM with comments https://chromiumcodereview.appspot.com/10703103/diff/1/src/objects.cc File src/objects.cc (right): https://chromiumcodereview.appspot.com/10703103/diff/1/src/objects.cc#newcode2863 src/objects.cc:2863: // From this point on everything ...
8 years, 5 months ago (2012-07-06 09:53:28 UTC) #2
Michael Starzinger
8 years, 5 months ago (2012-07-06 11:11:12 UTC) #3
Comments addressed. Landing.

https://chromiumcodereview.appspot.com/10703103/diff/1/src/objects.cc
File src/objects.cc (right):

https://chromiumcodereview.appspot.com/10703103/diff/1/src/objects.cc#newcode...
src/objects.cc:2863: // From this point on everything needs to be handlified,
because
On 2012/07/06 09:53:28, rossberg wrote:
> Actually, the point is after the special handling of JSGlobalProxy, which does
a
> recursive call into this same function again.

Done.

https://chromiumcodereview.appspot.com/10703103/diff/1/src/objects.cc#newcode...
src/objects.cc:2865: Handle<JSObject> object(this);
On 2012/07/06 09:53:28, rossberg wrote:
> Can we call it 'self', like in other places? That's a bit more descriptive.

Done. As discussed offline, in the long run this should be named "object" and
passed in as the first argument to a completely handlified method. But as a
interim solution I am fine with naming it "self" for now.

Powered by Google App Engine
This is Rietveld 408576698