Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(67)

Unified Diff: src/compiler.cc

Issue 10701157: Rename LChunkBase to LChunk, LChunk to LPlatformChunk and remove some unneeded explicit constructor… (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: Created 8 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/arm/lithium-codegen-arm.h ('k') | src/hydrogen.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler.cc
diff --git a/src/compiler.cc b/src/compiler.cc
index e341accd9071bcaa1c21692d9739203ab261cb52..22118ee4d05edae1b104769dbc6f7adf9a9ece31 100644
--- a/src/compiler.cc
+++ b/src/compiler.cc
@@ -312,7 +312,7 @@ static bool MakeCrankshaftCode(CompilationInfo* info) {
if (!graph->Optimize(&bailout_reason)) {
if (!bailout_reason.is_empty()) builder.Bailout(*bailout_reason);
} else {
- LChunkBase* chunk = LChunkBase::NewChunk(graph);
+ LChunk* chunk = LChunk::NewChunk(graph);
if (chunk != NULL) {
Handle<Code> optimized_code = chunk->Codegen();
if (!optimized_code.is_null()) {
« no previous file with comments | « src/arm/lithium-codegen-arm.h ('k') | src/hydrogen.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698