Index: chrome/common/extensions/api/web_navigation.json |
diff --git a/chrome/common/extensions/api/web_navigation.json b/chrome/common/extensions/api/web_navigation.json |
index 55342973f215121cd7e9ef8d5997bdc4114f852b..6a179a3c9387beabbd5b4f018ddbf278beb6d101 100644 |
--- a/chrome/common/extensions/api/web_navigation.json |
+++ b/chrome/common/extensions/api/web_navigation.json |
@@ -246,6 +246,27 @@ |
} |
} |
] |
+ }, |
+ { |
+ "name": "onTabReplaced", |
+ "type": "function", |
+ "description": "Fired when the contents of the tab is replaced by a different (usually previously pre-rendered) tab.", |
+ "options": { |
+ "supportsFilters": true, |
+ "supportsListeners": true, |
+ "supportsRules": false |
+ }, |
+ "parameters": [ |
+ { |
+ "type": "object", |
+ "name": "details", |
+ "properties": { |
+ "sourceTabId": {"type": "integer", "description": "The ID of the tab that was replaced."}, |
battre
2012/07/05 15:38:46
Should this be called "oldTabId"? How does "source
jochen (gone - plz use gerrit)
2012/07/06 11:13:50
What about replacedTabId
battre
2012/07/06 11:18:13
SGTM
|
+ "tabId": {"type": "integer", "description": "The ID of the tab that replaced the old tab."}, |
battre
2012/07/05 15:38:46
If the previous one becomes oldTabId, this might b
jochen (gone - plz use gerrit)
2012/07/06 11:13:50
I'd prefer to call this tabId, to be consistent wi
|
+ "timeStamp": {"type": "number", "description": "The time when the replacement happened, in milliseconds since the epoch."} |
+ } |
+ } |
+ ] |
} |
] |
} |