Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(429)

Unified Diff: lib/compiler/implementation/ssa/builder.dart

Issue 10440087: Compute liveness of instructions to get better and fewer variable names. (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 8 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « frog/tests/leg/type_inference_test.dart ('k') | lib/compiler/implementation/ssa/codegen.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: lib/compiler/implementation/ssa/builder.dart
===================================================================
--- lib/compiler/implementation/ssa/builder.dart (revision 8141)
+++ lib/compiler/implementation/ssa/builder.dart (working copy)
@@ -438,7 +438,10 @@
HParameterValue getActivationParameter(Element element) {
// If the element is a parameter, we already have a
- // HParameterValue for it.
+ // HParameterValue for it. We cannot create another one because
+ // it could then have another name than the real parameter. And
+ // the other one would not not it is just a copy of the real
+ // parameter.
if (element.isParameter()) return directLocals[element];
return builder.activationVariables.putIfAbsent(element, () {
« no previous file with comments | « frog/tests/leg/type_inference_test.dart ('k') | lib/compiler/implementation/ssa/codegen.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698