Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(22)

Issue 10829408: Smarter "new interesting code" detection. (Closed)

Created:
8 years, 4 months ago by Emily Fortuna
Modified:
8 years, 4 months ago
Reviewers:
vsm, sra1
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Smarter "new interesting code" detection. Committed: https://code.google.com/p/dart/source/detail?r=11186

Patch Set 1 : #

Total comments: 23

Patch Set 2 : #

Patch Set 3 : #

Patch Set 4 : #

Total comments: 13

Patch Set 5 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+273 lines, -194 lines) Patch
M tools/testing/perf_testing/run_perf_tests.py View 1 2 3 4 36 chunks +262 lines, -184 lines 0 comments Download
M tools/testing/webdriver_test_setup.py View 1 2 3 4 1 chunk +11 lines, -10 lines 0 comments Download

Messages

Total messages: 7 (0 generated)
Emily Fortuna
https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/webdriver_test_setup.py File tools/testing/webdriver_test_setup.py (right): https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/webdriver_test_setup.py#newcode42 tools/testing/webdriver_test_setup.py:42: help="Don't install Firefox", action='store_true', default=False) These were changes you ...
8 years, 4 months ago (2012-08-18 22:01:42 UTC) #1
sra1
https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_testing/run_perf_tests.py File tools/testing/perf_testing/run_perf_tests.py (right): https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_testing/run_perf_tests.py#newcode112 tools/testing/perf_testing/run_perf_tests.py:112: def _sync(self, revision_num=''): nit: we would usually use None ...
8 years, 4 months ago (2012-08-18 23:08:55 UTC) #2
Emily Fortuna
Made the change in this CL to actually only go forward for now. I left ...
8 years, 4 months ago (2012-08-20 19:59:04 UTC) #3
Emily Fortuna
Changed capitalization from Google External Style guide to the Chromium Style guide at sra's request.
8 years, 4 months ago (2012-08-20 20:36:39 UTC) #4
Emily Fortuna
bump, PTAL?
8 years, 4 months ago (2012-08-21 22:27:19 UTC) #5
sra1
lgtm https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_testing/run_perf_tests.py File tools/testing/perf_testing/run_perf_tests.py (right): https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_testing/run_perf_tests.py#newcode129 tools/testing/perf_testing/run_perf_tests.py:129: def sync_and_build(self, suites, revision_num=''): On 2012/08/20 19:59:05, Emily ...
8 years, 4 months ago (2012-08-21 22:59:36 UTC) #6
Emily Fortuna
8 years, 4 months ago (2012-08-22 21:08:20 UTC) #7
https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_...
File tools/testing/perf_testing/run_perf_tests.py (right):

https://chromiumcodereview.appspot.com/10829408/diff/2001/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:129: def sync_and_build(self,
suites, revision_num=''):
On 2012/08/21 22:59:36, sra1 wrote:
> On 2012/08/20 19:59:05, Emily Fortuna wrote:
> > On 2012/08/18 23:08:55, sra1 wrote:
> > > Google style is to use MixedCase for functions and methods.
> > 
> > Not for methods: 
> >
>
http://google-styleguide.googlecode.com/svn/trunk/pyguide.html?showone=Naming...
> > 
> > and there seems to be some vagueness here:
> > http://www.chromium.org/developers/coding-style
> 
> The second link says "Python code should follow PEP-8, except that Chromium
uses
> two-space indentation instead of four-space indentation, and it uses MixedCase
> for method names and function names instead of lower_case_with_underscores."

Yea, I was reading the wrong section of the style guide like we discussed.
Fixed.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
File tools/testing/perf_testing/run_perf_tests.py (right):

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:191: def HasInterestingCode(self,
past_revision_num=None):
On 2012/08/21 22:59:36, sra1 wrote:
> Why is it called 'past_revision_num'?

Silly historical reasons. Fixed.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:196: therefore the second element
in the tuple will be None.)"""
On 2012/08/21 22:59:36, sra1 wrote:
> Might be clearer if you said something like
> 
> Returns:
>   (False, None): ....
>   (True, past_revision_num):
>   (True, other_revision_num):
> 
> It might be simpler to return a revision number or None.

Done.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:212: def
GetChangedFileList(revision):
On 2012/08/21 22:59:36, sra1 wrote:
> You could just call it GetFileList.
> One might assume changed == modified, but we are intersted in added, moved and
> deleted files too.

Done.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:234: # that, we need to change our
original checkout.
On 2012/08/21 22:59:36, sra1 wrote:
> So in preparation for being able to match the DEPS changes, you could keep the
> dart prefix.

Done.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:260: results =
GetChangedFileList(latest_interesting_server_rev)
On 2012/08/21 22:59:36, sra1 wrote:
> better name: results -> filelist or files or filenames

Done.

https://chromiumcodereview.appspot.com/10829408/diff/9003/tools/testing/perf_...
tools/testing/perf_testing/run_perf_tests.py:1112: interesting_code_results =
runner.HasInterestingCode()
On 2012/08/21 22:59:36, sra1 wrote:
> Destructuring is often clearer and prevents bugs if you accidentally return
the
> wrong arity tuple
> 
> (is_interesting, interesting_revision) = runner.Has...
> if is_interersting:
>    runner.RunTestSequence(interesting_revision)
> 
> An alternative is to return the interesting revision number, or None.

Done.

Powered by Google App Engine
This is Rietveld 408576698