Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(383)

Issue 10690142: Move function serialization to sync ports. (Closed)

Created:
8 years, 5 months ago by Anton Muhin
Modified:
8 years, 4 months ago
Reviewers:
vsm, sammccall
CC:
reviews_dartlang.org, kasperl
Visibility:
Public.

Description

Move function serialization to sync ports. For now only dart to JS serialization. R=sammccall@google.com,vsm@google.com Committed: https://code.google.com/p/dart/source/detail?r=10750

Patch Set 1 #

Total comments: 8

Patch Set 2 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+82 lines, -12 lines) Patch
M client/dart.js View 1 3 chunks +17 lines, -0 lines 0 comments Download
M lib/html/src/Isolates.dart View 1 chunk +51 lines, -0 lines 0 comments Download
M lib/isolate/serialization.dart View 2 chunks +5 lines, -0 lines 0 comments Download
A + tests/html/js_interop_func_passing_test.dart View 2 chunks +9 lines, -12 lines 0 comments Download

Messages

Total messages: 5 (0 generated)
Anton Muhin
8 years, 5 months ago (2012-07-11 19:59:31 UTC) #1
Anton Muhin
Vijay, Kasper, a bit of context. Sam and me discussed it on the hackathon and ...
8 years, 5 months ago (2012-07-11 20:03:27 UTC) #2
vsm
https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js File client/dart.js (right): https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js#newcode92 client/dart.js:92: case 'funcref': return deserializeFunction(x); How about a more descriptive ...
8 years, 4 months ago (2012-08-10 00:18:50 UTC) #3
Anton Muhin
https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js File client/dart.js (right): https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js#newcode92 client/dart.js:92: case 'funcref': return deserializeFunction(x); On 2012/08/10 00:18:50, vsm wrote: ...
8 years, 4 months ago (2012-08-14 16:42:38 UTC) #4
vsm
8 years, 4 months ago (2012-08-15 15:35:36 UTC) #5
lgtm

https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js
File client/dart.js (right):

https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js#newcode92
client/dart.js:92: case 'funcref': return deserializeFunction(x);
It's fine for now.

On 2012/08/14 16:42:38, Anton Muhin wrote:
> On 2012/08/10 00:18:50, vsm wrote:
> > How about a more descriptive name?  E.g., 'function-proxy'.
> 
> I can definitely do it, but I wished to minimize the length of the tag to
reduce
> size of data to pass.
> 
> But if you think we'd better start with more descriptive tags and optimize for
> size later, I'll rename.

https://chromiumcodereview.appspot.com/10690142/diff/1/client/dart.js#newcode231
client/dart.js:231: return sendPort.callSync([ref,
Array.prototype.slice.call(arguments)]);
Yes, I think you're correct.

On 2012/08/14 16:42:38, Anton Muhin wrote:
> I don't remember all the details, but won't callSync take care of
> serialization/deserialization?
> 
> On 2012/08/10 00:18:50, vsm wrote:
> > Don't the arguments and return value need to be serialized and deserialized?
>

Powered by Google App Engine
This is Rietveld 408576698